« Converting to Weblogic 10.3 - Part 1 | Main | Converting to Weblogic 10.3 - Part 3 »

October 31, 2008

Comments

Feed You can follow this conversation by subscribing to the comment feed for this post.

Shaun Smith

Hi Michael,

WebLogic 10.3 has a patch that you can apply to install TopLink 11g as a JPA provider. If you're coming from GlassFish and using TopLink Essentials then migrating to TopLink 11g (which includes EclipseLink) is pretty straight forward.

Looking at what you had to do for Kodo I think that all you need to do to use TopLink 11g in WLS 10.3 would be to apply the patch (use the SmartPatch utility), rename the "toplink.*" properties in your your original TopLink Essentials persistence.xml file to "eclipselink.*", and set the provider to org.eclipse.persistence.jpa.PersistenceProvider.

TopLink is the strategic persistence solution for WebLogic server going forward which means migrating from GlassFish to WebLogic just got easier. ;-)

Shaun Smith
Eco-System Development Lead, EclipseLink
Principal Product Manager, Oracle TopLink

Pk

Smith,

Right now, we have toplink 9.0.4.6 with weblogic 8.1 SP4; we are planning to upgrade weblogic to 10.3. Do we need to modify or upgrade toplink as well? I found toplink needs to replace as eclipselink as comment in above. Can you provide little more details on this? I meant what are the steps that need to follow for this?

Regards,
PK

The comments to this entry are closed.